use strict;
my $str = 'InPascalCase
inCamelCase
in-kebab-case
in_snake_case
in-kebab_snake
in_snake-kebab
inCamel-kebab
inCamel_snake
InPascal-kebab
InPascal_snake
inCamel-kebab_snake
inCamel_snake-kebab
in_snakeCamel-kebab
in_snake-kebabCamel
in_snakeCamelCamel-kebab
in-kebabCamel_snakeCamel-kebab_snake';
my $regex = qr/([^\s\-_A-Z]+)|([A-Z]+[^\s\-_A-Z]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}