package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\s\-_A-Z]+)|([A-Z]+[^\s\-_A-Z]*)`)
var str = `InPascalCase
inCamelCase
in-kebab-case
in_snake_case
in-kebab_snake
in_snake-kebab
inCamel-kebab
inCamel_snake
InPascal-kebab
InPascal_snake
inCamel-kebab_snake
inCamel_snake-kebab
in_snakeCamel-kebab
in_snake-kebabCamel
in_snakeCamelCamel-kebab
in-kebabCamel_snakeCamel-kebab_snake`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}