# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[A-Z][a-z]+\s[A-Z][a-z]+(?:[^"']|"[^"]*"|'[^']*')*?\b\d{10}$//gm;t' <<< "Jennifer Ann from New York, \"Wisdom\" str, bl. 54, Ð’, with id 1234567890
Jennifer Ann\" from New York, \"Wisdom\" str, bl. 54, Ð’, with id 1234567890"