use strict;
my $str = 'Jennifer Ann from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890
Jennifer Ann" from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890';
my $regex = qr/^[A-Z][a-z]+\s[A-Z][a-z]+(?:[^"']|"[^"]*"|'[^']*')*?\b\d{10}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";