package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]+\s[A-Z][a-z]+(?:[^"']|"[^"]*"|'[^']*')*?\b\d{10}$`)
var str = `Jennifer Ann from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890
Jennifer Ann" from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}