// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^[A-Z][a-z]+\s[A-Z][a-z]+(?:[^"']|"[^"]*"|'[^']*')*?\b\d{10}$"#).unwrap();
let string = "Jennifer Ann from New York, \"Wisdom\" str, bl. 54, Ð’, with id 1234567890
Jennifer Ann\" from New York, \"Wisdom\" str, bl. 54, Ð’, with id 1234567890";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}