#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[A-Z][a-z]+\s[A-Z][a-z]+(?:[^"']|"[^"]*"|'[^']*')*?\b\d{10}$"
Local $sString = "Jennifer Ann from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890" & @CRLF & _
"Jennifer Ann" from New York, "Wisdom" str, bl. 54, Ð’, with id 1234567890"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)