using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*/\d+-\d+-\d+-\d+m|.*/\d+-\d+-\d+-\d+";
string input = @"account_name/2015-12-01-001m
account_name/2015-12-01-001
account_name/2015-12-01-
account_name/2015-12-001";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}