import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*/\\d+-\\d+-\\d+-\\d+m|.*/\\d+-\\d+-\\d+-\\d+";
final String string = "account_name/2015-12-01-001m\n"
+ "account_name/2015-12-01-001\n"
+ "account_name/2015-12-01-\n"
+ "account_name/2015-12-001";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}