const regex = new RegExp('.*/\\d+-\\d+-\\d+-\\d+m|.*/\\d+-\\d+-\\d+-\\d+', '')
const str = `account_name/2015-12-01-001m
account_name/2015-12-01-001
account_name/2015-12-01-
account_name/2015-12-001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}