import re
regex = re.compile(r".*/\d+-\d+-\d+-\d+m|.*/\d+-\d+-\d+-\d+")
test_str = ("account_name/2015-12-01-001m\n"
"account_name/2015-12-01-001\n"
"account_name/2015-12-01-\n"
"account_name/2015-12-001")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")