$re = '/.*/\d+-\d+-\d+-\d+m|.*/\d+-\d+-\d+-\d+/';
$str = 'account_name/2015-12-01-001m
account_name/2015-12-01-001
account_name/2015-12-01-
account_name/2015-12-001';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);