using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(_s_.*?_e_)((?:[^_]+$)?)";
string input = @"aaa_s_123abc_e_bbbccc_s_456def_e_bbbddd_s_7890_e_wwwddd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}