package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)(_s_.*?_e_)((?:[^_]+$)?)`)
var str = `aaa_s_123abc_e_bbbccc_s_456def_e_bbbddd_s_7890_e_wwwddd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}