const regex = /(.*?)(_s_.*?_e_)((?:[^_]+$)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(_s_.*?_e_)((?:[^_]+$)?)', 'gm')
const str = `aaa_s_123abc_e_bbbccc_s_456def_e_bbbddd_s_7890_e_wwwddd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}