$re = '/(.*?)(_s_.*?_e_)((?:[^_]+$)?)/m';
$str = 'aaa_s_123abc_e_bbbccc_s_456def_e_bbbddd_s_7890_e_wwwddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);