// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)(_s_.*?_e_)((?:[^_]+$)?)").unwrap();
let string = "aaa_s_123abc_e_bbbccc_s_456def_e_bbbddd_s_7890_e_wwwddd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}