import re
regex = re.compile(r"(.*?)(_s_.*?_e_)((?:[^_]+$)?)", flags=re.MULTILINE)
test_str = "aaa_s_123abc_e_bbbccc_s_456def_e_bbbddd_s_7890_e_wwwddd"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")