#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\D+?(?=-\d)"
Local $sString = " worda-wordb-1234.ds.er worda-wordb" & @CRLF & _
"worda-4567.we.ty worda" & @CRLF & _
"wordc-wordd-5698/de/ wordc-wordd" & @CRLF & _
"wordc-2356/rt/ wordc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")