import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\D+?(?=-\\d)";
final String string = " worda-wordb-1234.ds.er worda-wordb\n"
+ "worda-4567.we.ty worda\n"
+ "wordc-wordd-5698/de/ wordc-wordd\n"
+ "wordc-2356/rt/ wordc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}