$re = '/^\D+?(?=-\d)/m';
$str = ' worda-wordb-1234.ds.er worda-wordb
worda-4567.we.ty worda
wordc-wordd-5698/de/ wordc-wordd
wordc-2356/rt/ wordc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);