using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\D+?(?=-\d)";
string input = @" worda-wordb-1234.ds.er worda-wordb
worda-4567.we.ty worda
wordc-wordd-5698/de/ wordc-wordd
wordc-2356/rt/ wordc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}