re = /^\D+?(?=-\d)/m
str = ' worda-wordb-1234.ds.er worda-wordb
worda-4567.we.ty worda
wordc-wordd-5698/de/ wordc-wordd
wordc-2356/rt/ wordc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end