use strict;
my $str = ' worda-wordb-1234.ds.er worda-wordb
worda-4567.we.ty worda
wordc-wordd-5698/de/ wordc-wordd
wordc-2356/rt/ wordc';
my $regex = qr/^\D+?(?=-\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}