# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\bTest|(?!^)\G)[^_]*\K_/\\/g;t' <<< "Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo"