$re = '/(?:\bTest|(?!^)\G)[^_]*\K_/';
$str = 'Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo';
$subst = "\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;