re = /(?:\bTest|(?!^)\G)[^_]*\K_/
str = 'Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo'
subst = '\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result