use strict;
my $str = 'Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo';
my $regex = qr/(?:\bTest|(?!^)\G)[^_]*\K_/p;
my $subst = '\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";