import Foundation
let pattern = #"(?:\bTest|(?!^)\G)[^_]*\K_"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)