using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\bTest|(?!^)\G)[^_]*\K_";
string substitution = @"\\";
string input = @"Test_Interface extends
Test_Interface_Foo_Bar {
Test_FooBar implements
Test_FooBarFoo_Bar_Bar_Foo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}