package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Data Source\s*=\s*|Server=tcp:(.*?),|;`)
var str = `Server=tcp:SYD-SQLPROD01,1433;database=ARNOTTS_OSA_OOS; Integrated Security = SSPI
Data Source=SYD-SQLPROD01\blueprint,6143;Initial Catalog=MB_CTP_Live;Integrated Security=True
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}