re = /Data Source\s*=\s*|Server=tcp:(.*?),|;/
str = 'Server=tcp:SYD-SQLPROD01,1433;database=ARNOTTS_OSA_OOS; Integrated Security = SSPI
Data Source=SYD-SQLPROD01\\blueprint,6143;Initial Catalog=MB_CTP_Live;Integrated Security=True
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end