import Foundation
let pattern = #"Data Source\s*=\s*|Server=tcp:(.*?),|;"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Server=tcp:SYD-SQLPROD01,1433;database=ARNOTTS_OSA_OOS; Integrated Security = SSPI
Data Source=SYD-SQLPROD01\blueprint,6143;Initial Catalog=MB_CTP_Live;Integrated Security=True
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}