// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Data Source\s*=\s*|Server=tcp:(.*?),|;").unwrap();
let string = "Server=tcp:SYD-SQLPROD01,1433;database=ARNOTTS_OSA_OOS; Integrated Security = SSPI
Data Source=SYD-SQLPROD01\\blueprint,6143;Initial Catalog=MB_CTP_Live;Integrated Security=True
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}