const regex = new RegExp('Data Source\\s*=\\s*|Server=tcp:(.*?),|;', '')
const str = `Server=tcp:SYD-SQLPROD01,1433;database=ARNOTTS_OSA_OOS; Integrated Security = SSPI
Data Source=SYD-SQLPROD01\\blueprint,6143;Initial Catalog=MB_CTP_Live;Integrated Security=True
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}