import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Data Source\\s*=\\s*|Server=tcp:(.*?),|;";
final String string = "Server=tcp:SYD-SQLPROD01,1433;database=ARNOTTS_OSA_OOS; Integrated Security = SSPI\n"
+ "Data Source=SYD-SQLPROD01\\blueprint,6143;Initial Catalog=MB_CTP_Live;Integrated Security=True\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}