#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:[A-Z]\w+(?:\.com?)?[ -]+(?:&[ -]+)?){1,3}(?i:ltd|llc|inc|plc|co(?:rp)?|group|holding|gmbh)\b"
Local $sString = "I work in Amazon.com Inc." & @CRLF & _
"Company named Swiss Medic Holding invested in vaccine" & @CRLF & _
"what do you think about Abercrombie & Fitch Co. ?" & @CRLF & _
"do you work in Delta Group?" & @CRLF & _
"I have worked in CocaCola Gmbh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")