use strict;
my $str = 'I work in Amazon.com Inc.
Company named Swiss Medic Holding invested in vaccine
what do you think about Abercrombie & Fitch Co. ?
do you work in Delta Group?
I have worked in CocaCola Gmbh';
my $regex = qr/\b(?:[A-Z]\w+(?:\.com?)?[ -]+(?:&[ -]+)?){1,3}(?i:ltd|llc|inc|plc|co(?:rp)?|group|holding|gmbh)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}