import Foundation
let pattern = #"\b(?:[A-Z]\w+(?:\.com?)?[ -]+(?:&[ -]+)?){1,3}(?i:ltd|llc|inc|plc|co(?:rp)?|group|holding|gmbh)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I work in Amazon.com Inc.
Company named Swiss Medic Holding invested in vaccine
what do you think about Abercrombie & Fitch Co. ?
do you work in Delta Group?
I have worked in CocaCola Gmbh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)