using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[A-Z]\w+(?:\.com?)?[ -]+(?:&[ -]+)?){1,3}(?i:ltd|llc|inc|plc|co(?:rp)?|group|holding|gmbh)\b";
string input = @"I work in Amazon.com Inc.
Company named Swiss Medic Holding invested in vaccine
what do you think about Abercrombie & Fitch Co. ?
do you work in Delta Group?
I have worked in CocaCola Gmbh";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}