$re = '/\b(?:[A-Z]\w+(?:\.com?)?[ -]+(?:&[ -]+)?){1,3}(?i:ltd|llc|inc|plc|co(?:rp)?|group|holding|gmbh)\b/';
$str = 'I work in Amazon.com Inc.
Company named Swiss Medic Holding invested in vaccine
what do you think about Abercrombie & Fitch Co. ?
do you work in Delta Group?
I have worked in CocaCola Gmbh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);