import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[A-Z]\\w+(?:\\.com?)?[ -]+(?:&[ -]+)?){1,3}(?i:ltd|llc|inc|plc|co(?:rp)?|group|holding|gmbh)\\b";
final String string = "I work in Amazon.com Inc.\n"
+ "Company named Swiss Medic Holding invested in vaccine\n"
+ "what do you think about Abercrombie & Fitch Co. ?\n"
+ "do you work in Delta Group?\n"
+ "I have worked in CocaCola Gmbh";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}