#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<state>\S+)\s+(?P<connectivity>\S+)\s+(?P<wifi_hw>\S+)\s+(?P<wifi>\S+)\s+(?P<wwan_hw>\S+)\s+(?P<wwan>\S+)(?:\s+(?P<metered>.+)?)?$"
Local $sString = "connected full enabled enabled missing enabled no (guessed)" & @CRLF & _
"unknown none enabled enabled enabled disabled"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")