use strict;
my $str = 'connected full enabled enabled missing enabled no (guessed)
unknown none enabled enabled enabled disabled';
my $regex = qr/^(?P<state>\S+)\s+(?P<connectivity>\S+)\s+(?P<wifi_hw>\S+)\s+(?P<wifi>\S+)\s+(?P<wwan_hw>\S+)\s+(?P<wwan>\S+)(?:\s+(?P<metered>.+)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}