re = /^(?P<state>\S+)\s+(?P<connectivity>\S+)\s+(?P<wifi_hw>\S+)\s+(?P<wifi>\S+)\s+(?P<wwan_hw>\S+)\s+(?P<wwan>\S+)(?:\s+(?P<metered>.+)?)?$/m
str = 'connected full enabled enabled missing enabled no (guessed)
unknown none enabled enabled enabled disabled'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end