# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\"'](?:src|srcset)\s*=)\s*([\"'])(?!\s*\b(?:(?:bres|https?|ftp):\/\/|(?:data|javascript):))(?:file:\/\/)?[\x00-\x1f\x7f]*\.*\/?([^\">]+)\2/$1$2bres:\/\/dictid\/$3$2/gm;t' <<< "<img src=\"us.png\" srcset=\"us.png 1x, us-2x.png 2x\">
<img src=\"us.png\" srcset=\"us-2x.png 2x\">"