$re = '@([\s\"\'](?:src|srcset)\s*=)\s*([\"\'])(?!\s*\b(?:(?:bres|https?|ftp)://|(?:data|javascript):))(?:file://)?[\x00-\x1f\x7f]*\.*/?([^\">]+)\2@m';
$str = '<img src="us.png" srcset="us.png 1x, us-2x.png 2x">
<img src="us.png" srcset="us-2x.png 2x">';
$subst = "$1$2bres://dictid/$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;