const regex = new RegExp('([\\s\\"\\'](?:src|srcset)\\s*=)\\s*([\\"\\'])(?!\\s*\\b(?:(?:bres|https?|ftp)://|(?:data|javascript):))(?:file://)?[\\x00-\\x1f\\x7f]*\\.*/?([^\\">]+)\\2', 'gm')
const str = `<img src="us.png" srcset="us.png 1x, us-2x.png 2x">
<img src="us.png" srcset="us-2x.png 2x">`;
const subst = `$1$2bres://dictid/$3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);