using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s\""'](?:src|srcset)\s*=)\s*([\""'])(?!\s*\b(?:(?:bres|https?|ftp)://|(?:data|javascript):))(?:file://)?[\x00-\x1f\x7f]*\.*/?([^\"">]+)\2";
string substitution = @"$1$2bres://dictid/$3$2";
string input = @"<img src=""us.png"" srcset=""us.png 1x, us-2x.png 2x"">
<img src=""us.png"" srcset=""us-2x.png 2x"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}