import Foundation
let pattern = #"([\s\"'](?:src|srcset)\s*=)\s*([\"'])(?!\s*\b(?:(?:bres|https?|ftp)://|(?:data|javascript):))(?:file://)?[\x00-\x1f\x7f]*\.*/?([^\">]+)\2"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="us.png" srcset="us.png 1x, us-2x.png 2x">
<img src="us.png" srcset="us-2x.png 2x">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2bres://dictid/$3$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)